Jump to content
Welcome to iMobie Forum
John D

iMobie Cannot see iPhone7

Recommended Posts

installed iTunes and then iMobie…. Yet when running Phone Rescue, it stated that iTunes must be installed and will Not allow me to proceed ! Verified that iTunes recognizes my iPhone. Cant use your product if it doesn't work ! Glad I didn't buy it before testing it out....

Share this post


Link to post
Share on other sites

Hello John, thanks for using our app and we are truly sorry for the inconvenience may have caused to you. To start with, would you please kindly tell us which PhoneRescue and 

iTunes version are you using? 

Given this situation, here are our suggestions for you:

1. Please make sure you are using the latest version of PhoneRescue. If not, please download and install it from link below:

For Windows: https://www.imobie.com/go/download.php?product=pri&os=win

For Mac: https://www.imobie.com/go/download.php?product=pri&os=mac

2. Please make you have installed the latest version of iTunes and iTunes can recognize your device normally. If not, please reinstall iTunes. Here is the download link:

https://secure-appldnld.apple.com/itunes12/091-81692-20180709-A4DF288B-8929-401F-AD73-4189359D8A6B/iTunes64Setup.exe

3. Please click "trust" this computer when an alert asks on your device. 

Meanwhile, please do not open iTunes while launching PhoneRescue to avoid syncing data. 

If problem persists, would you please kindly send log file to Support@imobie.com for better analysis? We will try our best to find the issue and solution for you soon. 

https://www.imobie.com/faq/phonerescue-faqs.htm#part27

Sorry again for the inconvenience have caused to you.

Thank you so much for your generous support and kind feedback in advance. 

 

Share this post


Link to post
Share on other sites

iTunes version - 12.9.0.167

Phone Rescue - 3.7.0.20180716

Does device also need iTunes or just my laptop ? Thank you for your help.

Share this post


Link to post
Share on other sites

Hello, John, thank you so much for your kind feedback. You just need to install iTunes on your computer.

To start with, would you please kindly tell whether you are using Windows or Mac?

If you mean Mac, we have tested AnyTrans with iTunes 12.9.0.167 and found it is also compatible with macOS beta 10.14.

If possible, would you please kindly tell me your operating system version of your mac computer?

Thank you so much for your kind feedback in advance. 

 

Share this post


Link to post
Share on other sites

Hi, John, thanks for your kind feedback. We will test and send solution to you soon.

Thanks again for your support and patience on this issue.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×